не работает автозапуск Optware (SDK4, кажется)

медиацентр, transmission, интернет-сервисы и т.д.

не работает автозапуск Optware (SDK4, кажется)

Сообщение mega33 » 23 мар 2012, 21:35

Привет всем! Возник вопрос, как добавить в автозагрузку sshd из репозитария олега?
собственно, есть XDS6Lmk2 с последней расширенной прошивкой xfw_XDS6MK2_v9.5.31.r7277_(04.03.12)_2.01_RU и к нему optware_0.1_ru.icapp

1. ставлю openssh, он добавляет скрипт запуска /opt/etc/init.d/S40sshd
2. в веб-интерфейсе говорю включить S40sshd, добавляется скрипт /usr/local/etc/rcex.d/S40sshdoptware

Но автозапуск не срабатывает, хотя сами скрипты, если запускать руками, работают. Как это победить?

=======

решение отсюда http://forum.iconbit.ru/viewtopic.php?t=2585&f=40#p25089 не работает

В /usr/local/etc/profile обязательно добавить pathmunge /opt/etc/init.d
+ пункты 3, 3.1
mega33
 
Сообщения: 6
Зарегистрирован: 23 мар 2012, 21:09

Re: не работает автозапуск Optware (SDK4, кажется)

Сообщение tim1 » 12 май 2012, 12:35

Попробуй ещё вот этот вариант
viewtopic.php?f=67&t=10850&hilit=mediatomb&start=40
xfw_xds73d_v10.1.1.r8198_19.04.12_2.02_ru
tim1
 
Сообщения: 20
Зарегистрирован: 02 май 2012, 10:25

Re: не работает автозапуск Optware (SDK4, кажется)

Сообщение mega33 » 17 янв 2013, 16:53

Спасибо, победил по-своему, не мог сразу написать. В моем случае оказалось достаточно скопировать скрипт.
cp -dp /usr/local/etc/rcex.d/S40sshdoptware /tmp/hdd/root/app/etc/rcex.d

после этого все гуд, и настройка в веб-интерфейсе работает
mega33
 
Сообщения: 6
Зарегистрирован: 23 мар 2012, 21:09


Вернуться в Дополнительные модули (Realtek 1073/1283/1183/1185)



Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2